You are here

XStandard WYSIWYG Editor

Drupal Modules - Fri, 16/11/2007 - 5:44pm

This module integrates the standards-compliant XStandard WYSIWYG editor into Drupal.
XStandard meets very high accessiblity requirements, see this blog post at Standards Schmandards for a thorough comparison with other WYSIWYG editors.
A feature chart is available at the XStandard website.

Note that unlike TinyMCE and FCKeditor this is a browser plug-in that needs to be downloaded and installed on the client.

Supported platforms and browsers:

  • For Windows 2000, XP, Vista: IE 5.0+, Firefox 1.0+, Safari 3.0+ or Opera 9.0+
  • For OS X 10.3.9+: Firefox 1.0+ or Safari 1.3+

Note that XStandard is a proprietary product and not open source.

There are two versions of XStandard:

  • XStandard Lite (free for commercial use)
  • XStandard Pro (evaluation version available)